Commit 4802fe95 authored by Christoph Junghans's avatar Christoph Junghans Committed by Mathis Rosenhauer

cmake: require c99 standard

Some files, e.g. encode_accessors.c, use loop initial declarations
that are only allowed in C99 mode. Newer compilers enable that mode
automatically, but olders might fail. CMAKE_C_STANDARD got add in
CMake-3.1, so let's increase the minimal version by 0.1.
Signed-off-by: 's avatarChristoph Junghans <junghans@votca.org>
parent d808db1e
cmake_minimum_required(VERSION 3.0.0)
cmake_minimum_required(VERSION 3.1)
set(CMAKE_C_STANDARD 99)
include(CheckIncludeFiles)
include(TestBigEndian)
include(CheckCSourceCompiles)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment