Commit d7c6367b authored by Hendryk Bockelmann's avatar Hendryk Bockelmann
Browse files

add patch by Sergey Kosukhin to use autogen.sh with libtool higher than 2.4.2

parent 1c989af5
...@@ -4,7 +4,7 @@ verlte() { ...@@ -4,7 +4,7 @@ verlte() {
[ "$1" = "`echo -e "$1\n$2" | sort -V | head -n1`" ] [ "$1" = "`echo -e "$1\n$2" | sort -V | head -n1`" ]
} }
autoreconf -fvi autoreconf -fvi || exit $?
libtool_version=`libtool --version | awk 'NR==1 {print $4}'` libtool_version=`libtool --version | awk 'NR==1 {print $4}'`
...@@ -14,8 +14,10 @@ verlte $libtool_version 2.4.2 && { ...@@ -14,8 +14,10 @@ verlte $libtool_version 2.4.2 && {
patch --forward --no-backup-if-mismatch -p0 -s -l < maint/libtool.m4.patch patch --forward --no-backup-if-mismatch -p0 -s -l < maint/libtool.m4.patch
# rebuild configure # rebuild configure
autoconf -f || exit 1 autoconf -f || exit $?
# Reset libtool.m4 timestamps to avoid confusing make # Reset libtool.m4 timestamps to avoid confusing make
touch -r m4/ltversion.m4 m4/libtool.m4 touch -r m4/ltversion.m4 m4/libtool.m4
} }
\ No newline at end of file
exit 0
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment